راه اندازی لود بالانسینگ با متد NTH

0
Telegram_GEEKBOY

در این مقاله آموزشی قصد داریم با نحوه راه اندازی سرویس لودبالانسینگ با متد NTH آشنا شویم. این روش یکی از روش های ساده و کاربردی برای راه اندازی سرویس Load Balancing در میکروتیک برای چند لینک اینترنت هم وزن می باشد. هم وزن از نظر میزان پهنای باند مثلاً دو لینک Wan با پهنای باند هر لینک 1 مگابیت بر ثانیه.

گیگ بوی توسط سرور های قدرتمند هاست‌هی میزبانی میگردد


برای راه اندازی این سرویس در میکروتیک از ابزار های بخش Mangle برای علامت گذاری پکت های درون شبکه برای انتقال موازی بین دو لینک Wan استفاده می کنیم:

بهتر است برای interface های خود نامی مشخص قرار دهیم

interface ethernet
set 0 name=WAN1
set 1 name=WAN2
set 2 name=internal

interface

بعد از نام گذاری Interface ها باید روی آن ها آدرس IP را تنظیم کنیم:

/ip address

add address=192.168.50.2/24 network=192.168.50.0 broadcast=192.168.50.255 interface=WAN1

add address=192.168.51.2/24 network=192.168.50.0 broadcast=192.168.50.255 interface=WAN2

add address=192.168.22.1/24 network=192.168.22.0 broadcast=192.168.22.255 interface=internal

address

سپس با استفاده از ابزار Mangle متد nth را پیاده سازی کرده و پکت ها را علامت گذاری و برای آن ها Routing-Mark جداگانه ای تنظیم می کنیم:

/ip firewall mangle

add chain=prerouting in-interface=internal connection-state=new nth=2,1 action=mark-connection new-connection-mark=conn1 passthrough=yes

add chain=prerouting in-interface=internal connection-mark=conn1 action=mark-routing new-routing-mark=conn1 passthrough=no 

add chain=prerouting in-interface=internal connection-state=new nth=2,2 action=mark-connection new-connection-mark=conn2 passthrough=yes 

add chain=prerouting in-interface=internal connection-mark=conn2 action=mark-routing new-routing-mark=conn2 passthrough=no 

mangle

برای هر یک از کانکشن های فوق یک رول Nat از نوع Masquerade نیز ایجاد می کنیم:

/ip firewall nat

add chain=srcnat connection-mark=conn1 action=masquerade out-interface=WAN1 

add chain=srcnat connection-mark=conn2 action=masquerade out-interface=WAN2

nat

در نهایت با استفاده از رول های قسمت route ترافیک را به سمت Gateway های موجود ارسال می کنیم:

/ip route

add dst-address=0.0.0.0/0 gateway=192.168.50.1 scope=255 target-scope=10 routing-mark=conn1

add dst-address=0.0.0.0/0 gateway=192.168.51.1 scope=255 target-scope=10 routing-mark=conn2

add dst-address=0.0.0.0/0 gateway=192.168.50.1

add dst-address=0.0.0.0/0 gateway=192.168.51.1

route

منبع: blog.brahmani

در صورتی که مطالب سایت برای شما مفید بوده است، می توانید از طریق لینک زیر از سایت حمایت کنید.

ممکن است شما دوست داشته باشید بیشتر از نویسنده

ارسال یک نظر

آدرس ایمیل شما منتشر نخواهد شد.